Urgent Security Update required for all PDshop users to ensure compatibility with TLS 1.2
Urgent Security Update required for all PDshop users to ensure compatibility with TLS 1.2
You may have heard from some of your service providers about required security changes related to SSL, TLS, and PCI compliance.   The changes everyone is talking about are industry wide, very important for security, and the deadlines are fast approaching.  

If you use PDshop immediate ACTION IS REQUIRED to ensure your copy of PDshop and your web server are compatible with the newer TLS.  Even if you updated your copy of PDshop recently, additional action may be required as of today (3/4/2016).  

Today we released an update to PDshop that addresses an issue with the Microsoft .Net (Asp.Net) Framework’s support for TLS 1.2.   Because not all versions of Microsoft’s Asp.Net support TLS 1.2 (or it’s not enabled by default), we’ve added additional programming to PDshop and recompiled the main assembly to overcome this issue.  Without this update secure connections made by PDshop to credit card processors, payment gateways, shipping carriers, or other web services may begin to fail.  Your customers may receive errors when purchasing from you and you might not receive orders.  

TWO THINGS YOU NEED TO DO:

1. All copies of PDshop must be updated to version 10.058 (or higher) to prevent secure connections to credit card processors, payment gateways, shipping carriers, or other web services from failing.  

2. Make sure your website’s Asp.Net version is set to 4.0 (or higher) and up to date.  

Older versions of Asp.Net, including 1.1 and 2.0, will no longer be supported, as they do not support the newer TLS.  If you run your own web server, or are not that familiar with your hosting settings, we offer IT Services and can provide assistance with updating your server or testing it for compatibly issues.  

WHAT IF I AM USING A CUSTOM VERSION?
If you had us make a custom version for you, our team of developers are available.  Contact Us so that our developers can re-open your project and check to see what additional programming is needed.  

WHAT IF I MADE MY OWN CODE CHANGES OR YOU CAN’T UPGRADE?
If you modified code or simply can’t upgrade, Contact Us and let us know your PDshop version number and tell us about your situation and circumstances.  More than likely our developers can add any additional programming needed to your copy.  In most cases, we’d just have to add some code and recompile the primary Dll file for your specific version number.

We originally designed PDshop to always be backward and forward compatible with all the different versions of the Asp.Net.  Until now it has been, however with service providers disabling older versions of TLS, and Asp.net’s lack of support for newer TLS in some versions, some programming changes are needed and we can only support newer versions of Asp.Net going forward.  We are recommending immediate action because the deadlines set by the various service providers are fast approaching (some of the deadlines are only a few weeks away).  
Related Articles
Other Resources
Related Topics
Search for help...

IMPORTANT

IMPORTANT update for 2019. All users should install the Latest Update for 2019. If you are using 10.067 or earlier, you need to update to 10.068 or higher.